Eine neue Java Version kann man nach /usr/lib64/jvm verschieben und mit:

update-alternatives --install \
/usr/bin/java java /usr/lib64/jvm/jdk1.7.0_45/jre/bin/java 120 \
--slave /usr/bin/keytool  keytool  /usr/lib64/jvm/jdk1.7.0_45/jre/bin/keytool \
--slave /usr/bin/rmiregistry rmiregistry /usr/lib64/jvm/jdk1.7.0_45/jre/bin/rmiregistry
update-alternatives --install /usr/bin/javac javac /usr/lib64/jvm/jdk1.7.0_45/bin/javac 120 \
--slave /usr/bin/jar  jar  /usr/lib64/jvm/jdk1.7.0_45/bin/jar \
--slave /usr/bin/rmic rmic /usr/lib64/jvm/jdk1.7.0_45/bin/rmic

installieren.

Auswählen kann man dann die Version mit
update-alternatives --config javac
update-alternatives --config java

Java Security

sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: algorithm constraints check failed
In java.security 'jdk.certpath.disabledAlgorithms=MD2, RSA keySize < 1024' auskomentieren